Email Processing

Incident Report for Digistore24

Resolved

Emails are being processed again and the issue has been resolved. Emails sent to our system during the incident will have bounced and need to be resent in order to reach us.
Posted Apr 22, 2021 - 14:55 CEST

Monitoring

We have rolled out a fix and are actively monitoring the situation to validate its sustainability.
Posted Apr 22, 2021 - 11:52 CEST

Identified

We have identified the issue and are working on a fix.
Posted Apr 22, 2021 - 10:14 CEST

Investigating

We are experiencing issues processing incoming Emails to the domain coachannel.com as well as sending email with that domain and are currently investigating the issue.
Posted Apr 22, 2021 - 10:09 CEST
This incident affected: Digibiz24.