Some Custom domains are not reachable

Incident Report for Digistore24

Resolved

The fix is in place and may take some time to propagate to all affected domains.
All domains should work within the next 30m
Posted Sep 18, 2025 - 12:39 CEST

Identified

Custom domains that still point to cd.coachannel.com are currently not reachable. The team is working on a fix.

Workaround: Set your CNAME to point to cd.digibiz24.com

Please note, domains already pointing to cd.digibiz24.com are fully functional and not affected.
Posted Sep 18, 2025 - 12:31 CEST
This incident affected: Digibiz24.