Partial Outage: Direct Debit Payments

Incident Report for Digistore24

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 12:49 CEST

Identified

Direct Debit (SEPA) payments are currently not fully available. As a result, some rebilling attempts may fail.

You may receive error notifications related to failed payments. These can be ignored — we are actively handling all affected transactions on our side.

No action is required from your side. We’ll update this status once the issue is fully resolved.

Thank you for your patience.
Posted Jul 16, 2025 - 22:04 CEST
This incident affected: Digistore24.