Digibiz24 sometimes is not reachable
Incident Report for Digistore24
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 05, 2025 - 13:51 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 05, 2025 - 10:08 CET
Investigating
We are currently investigating this issue.
Posted Feb 05, 2025 - 09:54 CET
This incident affects: Digibiz24.