Digistore24 Currently Unavailable

Incident Report for Digistore24

Resolved

The service is fully functional and back to operation
Posted May 18, 2026 - 16:36 CEST

Update

We are continuing to investigate this issue.
Posted May 18, 2026 - 16:35 CEST

Update

We are continuing to investigate this issue.
Posted May 18, 2026 - 16:26 CEST

Investigating

Due to technical issues Digistore24 is currently unavailable. We understand the utmost importance of providing an uninterrupted service: our engineers are aware and investigate potential causes with top priority. We will publish updates ASAP.
Posted May 18, 2026 - 16:26 CEST
This incident affected: Digistore24.