Coachannel partly unavailable
Incident Report for Digistore24
Resolved
This incident has been resolved.
Posted Feb 28, 2022 - 12:16 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 28, 2022 - 12:14 CET
Investigating
We are having problems with Coachannel not being available for all users. We are actively investigating the issue and will post updates as soon as we have them.
Posted Feb 28, 2022 - 12:04 CET
This incident affected: Digibiz24.