Issues with videoplayback on iOS mobile browser
Incident Report for Digistore24
Resolved
The incident has been resolved and videos are now working again on iOS mobile browser.

Other browsers (Web on Mac / Windows) and the Mobile App (iOS / Android) were not affected.
Posted Jun 10, 2024 - 15:08 CEST
Investigating
We are currently investigating issues with video playback on iOS devices, for videos hosted by Digibiz
Posted Jun 10, 2024 - 14:43 CEST
This incident affected: Digibiz24.