Currently our database cluster
Incident Report for Digistore24
Resolved
We thank Amazon for their good and fast support. The database cluster is up and running again. Digistore24 is online again.
Posted Apr 29, 2020 - 23:32 CEST
Investigating
Currently our database cluster is down. We are investigating. We don't expect data loss.

Until the issue is resolved, our service is not avialable.
Posted Apr 29, 2020 - 22:47 CEST
This incident affected: Digistore24.