Coachannel slow and sometimes unreachable
Incident Report for Digistore24
Resolved
This incident has been resolved.
Posted Apr 07, 2021 - 19:41 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2021 - 19:25 CEST
Investigating
We are currently investigating this issue.
Posted Apr 07, 2021 - 18:31 CEST
This incident affected: Coachannel.