Outbound mail delivery delayed
Incident Report for Digistore24
Resolved
The queues have been delivered and all eMail Services are back to normal.
Posted Dec 17, 2022 - 14:31 CET
Monitoring
Our mail provider is online again and working through the queue of unsent messages. It will take some time until this is done and we are actively monitoring the situation.

So, emails are delivered with a delay at the moment but the situation is improving by the minute.
Posted Dec 17, 2022 - 13:55 CET
Identified
We identified a problem with our mail provider. A percentage of our outbound mails for our applications and support system are delayed. We already informed our mail provider who is working on it. We are currently expecting a fix. Thank you for patience and understanding
Posted Dec 17, 2022 - 11:49 CET
This incident affected: Digistore24 and Digibiz24.